BGP IP Routing Protocols Routing tech

How To Configure IPv6 Routing over an IPv4 BGP Session

How To Configure IPv6 Routing over an IPv4 BGP Session

BGP Help for IPv6

Border Gateway Protocol BGP is the ‘massive canine’ routing protocol on the Web.
One of many draw back with conventional BGP model Four (BGP-Four) is that it solely supported the routing of IPv4 networks.
However Wallah!…there got here an replace to BGP, referred to as Multiprotocol BGP (MP-BGP),

This up to date model features a set of multiprotocol extensions which permits BGP to help numerous handle varieties.

Multiprotocol BGP (MP-BGP) Fundamentals
MP-BGP permits for the mixture or makes use of of quite a lot of protocol varieties beneath a single BGP configuration.
These protocol varieties are referred to as handle households and embrace:
■ Unicast IPv4
■ Multicast IPv4
■ Unicast IPv6
■ Multicast IPv6

In essence… MP-BGP helps a number of further handle households, largely used to help virtualization applied sciences, corresponding to Digital Personal LAN Service (VPLS) and Layer 2 VPN
(L2VPN).

MP-BGP accommodates a number of new parts and options not present in BGP-Four, together with:

■ Tackle Household Identifier (AFI): Specifies the kind of tackle being utilized by an Tackle Household.

■ Subsequent Tackle Household Identifier (SAFI): Supplies further tackle household info for some handle households.

■ Multiprotocol Reachable Community Layer Reachability Info (MP_REACH_
NLRI): An up to date attribute that transports a set of reachable networks, together with next-hop info.

■ Multiprotocol Unreachable Community Layer Reachability Info (MP_UNREACH_NLRI): An attribute that transports a set of unreachable networks (used to point that particular beforehand reachable networks are unreachable).

■ BGP Capabilities Commercial: Utilized by a router to inform a neighboring or peering router its BGP capabilities—used throughout BGP session negotiation.

      That is the Fascinating bits…

Its additionally recognized that the multiprotocol extensions contained within the up to date MP-BGP making it backward suitable with conventional BGP-Four. Consequently, a standard BGP-Four router can type a neighborship with an MP-BGP router, and easily ignore any acquired BGP messages containing unrecognized extensions.

IPv6 Routing over an IPv4 BGP Session

MP-BGP routers can trade updates for quite a lot of handle households over an IPv4 BGP session.
To configure IPv6 routing over an IPv4 BGP session, comply with the steps under:

Step 1. You allow IPv6 routing with the ipv6 unicast-routing command, in international configuration
mode.

Step 2. Create a route map by issuing the route-map route_map_name command, in international configuration mode.

Step three. Specify the IPv6 handle of the router’s interface connecting to a neighbor as a next-hop IPv6 handle, utilizing the set ipv6 next-hop ipv6_address, in route map configuration mode.

Step Four. Outline the BGP autonomous system with the router bgp as-number command, in international configuration mode.

Step 5. Outline an IPv4 BGP neighbor with the neighbor neighbor’s_ipv4_address remote-as command, in router configuration mode.

Step 6. Enter handle household configuration mode for the IPv4 handle household with the address-family ipv4 command, in router configuration mode.

Step 7. Specify which interfaces will take part within the IPv4 tackle household by issuing a number of community ip4_network_address [ mask subnet_mask ] instructions, in IPv4 tackle household configuration mode. (Observe: The neighbor neighbor’s_ipv4_address activate command is routinely entered for you in IPv4
tackle household configuration mode.)

Step eight. Exit IPv4 tackle household configuration mode with the exit-address-family command, in IPv4 handle household configuration mode.

Step 9. Enter tackle household configuration mode for the IPv6 handle household with the address-family ipv6 command, in router configuration mode.

Step 10. Specify which interfaces will take part within the IPv6 handle household by issuing a number of community ipv6_network_address/prefix-length instructions, in IPv6 handle household configuration mode.
Step 11. Activate the BGP neighbor for the IPv6 handle household with the neighbor neighbor’s_ipv4_address activate command, in IPv6 handle household configuration mode.

Step 12. Affiliate the beforehand configured route map (which specifies the next-hop IPv6 handle to promote to a neighbor) with the neighbor utilizing the neighbor neighbor_ipv4_address route-map route_map_name out command, in IPv6 tackle household configuration mode.

       okay…sufficient speak…

Let’s use the BGP AS community topology under for instance.

Within the determine above, two BGP autonomous techniques are configured with each IPv4 and IPv6 networks. The BGP session between Routers R1 and R2 is an IPv4 BGP session.

Nevertheless, each IPv4 and IPv6 route updates are exchanged over the IPv4 BGP session.

IPv6 over IPv4 BGP Session—R1 Configuration instance:

R1(config)#ipv6 unicast-routing

! *** OUTPUT OMITTED ***
R1(config)# router bgp 52401
R1(config-router)#neighbor 192.168.100.2 remote-as 52402
!
R1(config-router)#address-family ipv4
R1(config-router)#community 172.16.2.1
R1(config-router)#neighbor 192.168.100.2 activate
R1(config-router)#exit-address-family
!
R1(config-router)#address-family ipv6
R1(config-router)#community 2000:1::/64
R1(config-router)#neighbor 192.168.100.2 activate
R1(config-router)#neighbor 192.168.100.2 route-map IPV6-NEXT-HOP out
R1(config-router)#exit-address-family
! *** OUTPUT OMITTED ***
R1(config-router)#route-map IPV6-NEXT-HOP allow 10
R1(config-router)#set ipv6 next-hop 2000:2::1

In instance configuration above, Router R1 belongs to AS 52401 and is forming a neighborship with Router R2, which has an IPv4 handle of 192.168.100.2 and resides in AS 52402.

Then, in IPv4 handle household configuration mode, the community 172.16.2.zero command was issued to allow Router R1’s Fa zero/zero interface to take part within the IPv4 handle household.

The neighbor 192.168.100.2 activate command is mechanically entered in IPv4 tackle household configuration mode, to activate the beforehand configured neighbor for the IPv4 handle household.

In IPv6 handle household configuration mode, the community 2000:1::/64 command is issued to make Router R1’s Fa zero/zero interface take part within the IPv6 tackle household.

Additionally, in contrast to the IPv4 handle household, the BGP neighbor (192.168.100.2) configuration needs to be manually activated to affiliate the preconfigured neighbor with the IPv6 handle household. That is executed with the neighbor 192.168.100.2 activate command.

Lastly, in IPv6 tackle household configuration mode, the neighbor 192.168.100.2 route-map IPV6-NEXT-HOP out command is issued. This command allows BGP route ads despatched to Router R2 to specify Router R1’s Fa zero/1 IPv6 tackle as an IPv6 next-hop handle, as specified within the IPV6-NEXT-HOP route map.

The beforehand talked about route map is created with the route-map IPV6-NEXT-HOP allow 10 command.

Then, in route map configuration mode, the set ipv6 next-hop 2000:2::1 command was entered to specify the IPv6 handle of Router R1’s Fa zero/1 interface because the next-hop IPv6 tackle that Router R2 ought to use when trying to succeed in IPv6 networks marketed by Router R1.

With out this route map instruction, Router R2 will obtain IPv6 route ads, however these ads won’t have a reachable next-hop tackle and subsequently won’t be injected into Router R2’s IPv6 routing desk.

Configuration instance under exhibits the peering configuration on Router R2.
IPv6 over IPv4 BGP Session—R2 Configuration

R2(config)#ipv6 unicast-routing
! *** OUTPUT OMITTED ***
R2(config)#router bgp 52402
R2(config-router)#neighbor 192.168.100.1 remote-as 52401
!
R2(config-router)#address-family ipv4
R2(config-router)#community 200.1.112.zero
R2(config-router)#neighbor 192.168.100.1 activate
R2(config-router)#exit-address-family
!
R2(config-router)#address-family ipv6
R2(config-router)#community 2000:three::/64
R2(config-router)#neighbor 192.168.100.1 activate
R2(config-router)#neighbor 192.168.100.1 route-map IPV6-NEXT-HOP out
R2(config-router)#exit-address-family
! *** OUTPUT OMITTED ***
R2(config-router)#route-map IPV6-NEXT-HOP allow 10
R2(config-router)#set ipv6 next-hop 2000:2::2

The present ipv6 route command issued on each Routers R1 and R2, as seen within the instance under, confirms that Routers R1 and R2 are exchanging IPv6 routing info.

Instance present ipv6 route Output on ROUTER R1

R1# present ipv6 route
IPv6 Routing Desk – default – 6 entries
Codes: C – Related, L – Native, S – Static, U – Per-user Static route
B – BGP, R – RIP, H – NHRP, I1 – ISIS L1
I2 – ISIS L2, IA – ISIS interarea, IS – ISIS abstract, D – EIGRP
EX – EIGRP exterior, ND – ND Default, NDp – ND Prefix, DCE – Vacation spot
NDr – Redirect, O – OSPF Intra, OI – OSPF Inter, OE1 – OSPF ext 1
OE2 – OSPF ext 2, ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2, l – LISP
C 2000:1::/64 [0/0]by way of FastEthernet0/zero, immediately related
L 2000:1::1/128 [0/0]by way of FastEthernet0/zero, obtain
C 2000:2::/64 [0/0]by way of FastEthernet0/1, instantly related
L 2000:2::1/128 [0/0]by way of FastEthernet0/1, obtain
B 2000:three::/64 [20/0]by way of FE80::C801:13FF:FE74:eight, FastEthernet0/1
L FF00::/eight [0/0]by way of Null0, obtain

ROUTER R2 

R2# present ipv6 route
IPv6 Routing Desk – default – 6 entries
Codes: C – Related, L – Native, S – Static, U – Per-user Static route
B – BGP, R – RIP, H – NHRP, I1 – ISIS L1
I2 – ISIS L2, IA – ISIS interarea, IS – ISIS abstract, D – EIGRP
EX – EIGRP exterior, ND – ND Default, NDp – ND Prefix, DCE – Vacation spot
NDr – Redirect, O – OSPF Intra, OI – OSPF Inter, OE1 – OSPF ext 1
OE2 – OSPF ext 2, ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2, l – LISP
B 2000:1::/64 [20/0]by way of FE80::C800:13FF:FE74:6, FastEthernet0/zero
C 2000:2::/64 [0/0]by way of FastEthernet0/zero, instantly related
L 2000:2::2/128 [0/0]by way of FastEthernet0/zero, obtain
C 2000:three::/64 [0/0]by way of FastEthernet0/1, immediately related
L 2000:three::1/128 [0/0]by way of FastEthernet0/1, obtain
L FF00::/eight [0/0]by way of Null0, obtain

The present bgp ipv6 unicast command, as seen within the instance under, shows IPv6 networks recognized to BGP, together with next-hop info to succeed in these networks.

Word that a next-hop handle of :: signifies that the community is native to the router.

Instance present bgp ipv6 unicast Output on ROUTER R1

R1# present bgp ipv6 unicast
BGP desk model is three, native router ID is 192.168.100.1
Standing codes: s suppressed, d damped, h historical past, * legitimate, > greatest, i – inner,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i – IGP, e – EGP, ? – incomplete
RPKI validation codes: V legitimate, I invalid, N Not discovered
Community Subsequent Hop Metric LocPrf Weight Path
*> 2000:1::/64 :: zero 32768 i
*> 2000:three::/64 2000:2::2 zero zero 64702 i

ROUTER R2

R2# present bgp ipv6 unicast
BGP desk model is three, native router ID is 200.1.112.1
Standing codes: s suppressed, d damped, h historical past, * legitimate, > greatest, i – inner,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i – IGP, e – EGP, ? – incomplete
RPKI validation codes: V legitimate, I invalid, N Not discovered
Community Subsequent Hop Metric LocPrf Weight Path
*> 2000:1::/64 2000:2::1 zero zero 64701 i
*> 2000:three::/64 :: zero 32768 i